Intermittent Mastercard payment issues
Incident Report for Spektrix
Resolved
Our partners have advised that the issues processing Mastercard 3D secure challenges are now resolved, and transactions should be processing again as normal.

If you have any further questions on this, please don't hesitate to contact Support at support@spektrix.com.
Posted Jun 12, 2023 - 17:18 BST
Identified
We've identified issues processing some Mastercard payments, specifically a high rate of failures on 3D secure challenges. We understand this to be a Mastercard wide issue.

We'll continue to work with our partners on this, but would advise that if customers are encountering issues, that they attempt a different card.
Posted Jun 12, 2023 - 15:29 BST
This incident affected: Payments Processing (Opayo (formerly SagePay)).