System slowness and error pages

Incident Report for Spektrix

Resolved

All system speeds have returned to expected levels, and the number of error pages being reached has reduced significantly.
We will continue to monitor closely and will update here if there are any further issues.

We apologise for the disruption this has caused to those of you who experienced issues today.

We are aware that there have been several issues recently that have had a similar level of disruption over the last few days and weeks. System stability is an area we take pride in, and we are continuously making improvements in this area. We are treating the underlying causes of the recent issues as the highest priority to resolve, and we have made significant progress on this recently.

If anyone has any further concerns or questions, please don't hesitate to reach out to us via our Client Success team (support@spektrix.com / support.spektrix.com) and we will be happy to address them.

Thanks again for your patience as we worked to resolve things today.
Posted Mar 28, 2025 - 15:08 GMT

Update

We are continuing to work through the fix to bring all systems back up to normal speeds and reduce error pages. You may find that your system is already back up and running fully as we work through this.

We'll keep you updated as our work progresses on this.
Posted Mar 28, 2025 - 14:34 GMT

Identified

We're aware that some users are experiencing system slowness and error pages - either a green Spektrix error screen or a more generic error page.
We are continuing to work on resolving this, and believe that after taking further steps to resolve this slowness it will have a significant positive impact on previous issues we have had.
We will continue to update as we work through this issue now.
Posted Mar 28, 2025 - 14:09 GMT
This incident affected: Spektrix System (UK and Ireland, US and Canada).