US/CA Limited phone support
Incident Report for Spektrix
Resolved
US/CA phone service has been restored and you should be able to reach us as normal. Thank you again for your patience!
Posted 13 days ago. Oct 07, 2019 - 19:55 BST
Investigating
We are currently experiencing outages with phone service in the NY Office. This issue is currently being investigated. We are still available to be reached via email and we will be actively monitoring all voice messages. Thank you for your patience.
Posted 13 days ago. Oct 07, 2019 - 17:13 BST
This incident affected: Support Services (Phone Service - North America).