Issues with reports and customer lists running slowly
Incident Report for Spektrix
Resolved
There should now be no delays when running reports and customer lists. In addition, tasks such as bulk adding tags and updating overlays will now also be running normally.

Thank you for your understanding whilst we looked into this.
Posted Oct 19, 2023 - 16:19 BST
Monitoring
We are seeing issues with some jobs from the system, such as the running of reports and customer lists, taking a long time to run.

We have identified the issue and implemented a fix. You should start to see improvements within the next few minutes.
Posted Oct 19, 2023 - 15:48 BST
This incident affected: Spektrix System (UK and Ireland, US and Canada).