Payments not available via Adyen Gateway

Incident Report for Spektrix

Resolved

Payment processing through Adyen has been stabilised since around 1.15am BST / 8.15pm EDT, and Adyen have now marked the issue as resolved. All payments should now be going through normally.
Posted Apr 22, 2025 - 08:18 BST

Update

21:14 BST / 16:14 EST Update:
Adyen is continuing to experience problems that started around 19:35 BST / 14:35 EDT today. During this time you may experience issues with processing card payments in the Sales interface and through your websites. We are continuing to monitor the situation across our Spektrix Payments users in North America, the UK, and Ireland and will post updates as we are made aware of them.

For real time updates, you can also view Adyen's status page: https://status.adyen.com/
Posted Apr 21, 2025 - 21:15 BST

Update

We are continuing to work on a fix for this issue.
Posted Apr 21, 2025 - 20:17 BST

Identified

Adyen is experiencing degraded performance that resurfaced today around 19:35 BST / 14:35 EDT. Those who use Spektrix Payments as their payment provider may be affected and be unable to take payments. We suspect this may affect all Spektrix clients on Adyen including those in the US, CA, UK and Ireland. For real time updates, you can subscribe to Adyen's status page: https://status.adyen.com/
Posted Apr 21, 2025 - 20:03 BST
This incident affected: Payments Processing (Spektrix Payments (Adyen)).