We're happy that all aspects of Spektrix Subsites and Spektrix Link are now fully operational. If you are still seeing problems loading pages after syncing your page then please get in touch with us and we can further assist.
Posted Jan 27, 2026 - 13:49 UTC
Monitoring
We have been able to identify the issue causing this. We have rolled out a fix for this. For this to take effect it the Subsite itself will need to sync. This automatic process happens every 15 minutes or can be manually triggered from within the Spektrix Link admin.
We have manually synced subsites for organisations we know have reported issues, and if you would like any assistance in running a manual sync please contact us and we can help with that.
Posted Jan 27, 2026 - 12:49 UTC
Investigating
We're investigating an issue affecting Spektrix Subsites only. The Event Availability page is currently displaying "No events available" when there are online events that should be displayed.
Navigating to an event directly via an ID does work, it is currently only the Event Availability page affected.
We will provide more updates as soon as we have them.