Some clients experiencing system slowness
Incident Report for Spektrix
Resolved
We're happy all system speeds have returned to expected levels now. We are continuing to monitor but the fix we have implemented is in place and we can see response times are back to normal.
Posted Oct 01, 2024 - 13:49 BST
Monitoring
Systems speeds have returned to normal following the implementation of the fix. Some clients may have experienced slowness in their Spektrix system and on their website between 12:45 BST / 07:45 EDT and 13:20 BST / 08:20 EDT.

We are continuing to monitor this closely.
Posted Oct 01, 2024 - 13:30 BST
Update
As the fix is implemented across systems, we are seeing improved click speeds and response times. This includes on websites.

We are continuing to monitor this closely as the fix is applied to all systems.
Posted Oct 01, 2024 - 13:23 BST
Update
We believe we have identified the cause of this issue and are looking to implement a fix to improve system speeds.

The slowness will also be impacting websites, and you may notice queues trigger briefly before clearing, as well as slow clicks around your website.
Posted Oct 01, 2024 - 13:12 BST
Identified
Some clients are currently experiencing system slowness, which started around 12:45 BST / 07:45 EDT.

We are currently investigating this as a priority.
Posted Oct 01, 2024 - 13:03 BST
This incident affected: Spektrix System (UK and Ireland, US and Canada).