Spektrix Downtime
Incident Report for Spektrix
Resolved
We have been continuing to monitor system performance and we are confident that the issues from July 11 have been resolved. You should see that access to the system and system speeds have returned to normal.

This period of degraded system performance was extremely disruptive and we’re sorry for the impact this has had on you and your customers. We'll be providing a full explanation of the reasons for the issues in the coming days, but in the meantime our Support team are on hand to help on support@spektrix.com or 1-(800)-961-5971.
Posted 3 months ago. Jul 12, 2019 - 11:27 BST
Update
Spektrix is now available for our North American clients, though we're continuing to experience slowness with the system. We will continue to keep you updated.
Posted 3 months ago. Jul 11, 2019 - 23:03 BST
Update
Spektrix is about to become unavailable for our North American clients as we address the ongoing system issues. This should last less than one hour. Our engineers are working to get things back up and running as soon as possible; we'll keep you posted here as soon as the system is available again.
Posted 3 months ago. Jul 11, 2019 - 22:18 BST
Update
Spektrix is now available for our North American clients, though we're experiencing some slowness with the system. Thanks for bearing with us.
Posted 3 months ago. Jul 11, 2019 - 15:15 BST
Investigating
Spektrix is currently unavailable for our North American clients. This should just be for a short period of time. Our engineers are working to get things back up and running as soon as possible; we'll keep you posted here as soon as the system is available again.
Posted 3 months ago. Jul 11, 2019 - 15:05 BST
This incident affected: Spektrix System (Spektrix System - US/CAN) and APIs (APIs - US/CAN).