Spektrix Box Office App not connecting
Incident Report for Spektrix
Resolved
We have continued to monitor the Box Office App performance closely, and are confident it has remained in a stable position.

From 11:30 BST / 06:30 EDT - 17:45 BST / 12:45 EDT on Monday 14 October, the Box Office App was unavailable. This meant that in-person chip & pin payments and ticket printing were not possible in this time period. This was caused by an upgrade to an underlying technology service the Box Office App runs on. That upgrade didn't roll out as expected and took significant resetting to get back to normal. Now this is resolved and stable, these issues shouldn't reoccur.

There may be a small number of cases where you are required to re-install the Box Office App. We have detailed guidance of the steps required on our Support Centre, but if you require assistance or further guidance, please do reach out to our team.

Thank you for your patience and understanding whilst we worked to resolve this.
Posted Oct 15, 2024 - 12:41 BST
Monitoring
We have been able to fully implement a fix to resolve the connectivity issues with the Box Office App. If you now attempt to restart or re-register your Box Office App, this will be successful.

There may be a small number of cases where you are required to re-install the Box Office App. We have detailed guidance of the steps required on our Support Centre, but if you require assistance or further guidance, please do reach out to our team.

From 11:30 BST / 06:30 EDT - 17:45 BST / 12:45 EDT the Box Office App was unavailable. This meant that in-person chip & pin payments and ticket printing were not possible in this time period. Chip payments would have remained possible for all clients using Spektrix Payments.

Thank you for your patience and understanding whilst we worked to resolve this. The issues experienced with the Box Office App today are unrelated to the problems with system performance that we saw last week, and we understand that this will have had an impact on your operations.
Posted Oct 14, 2024 - 17:57 BST
Update
We are continuing to work on restoring Box Office App connectivity as a priority.

For those who urgently require a solution to print and take in-person payments, please consider:
- Taking in-person payments using the 'card' option, where you enter the long card number as if you were on the phone
- Running occupancy reports for event admittance, which can be run within the Sales Interface underneath each Event Instance.

Please reach out to the team if you need assistance with these.
Posted Oct 14, 2024 - 17:26 BST
Update
As part of our ongoing efforts to resolve the connectivity issues with the Box Office App, you may have seen a notification that the Box Office App has now connected successfully.

We are still in the process of rolling out the fix, and this does not yet mean that you'll be able to connect via Local Settings to successfully take in-person chip & pin payments or print tickets.

We are working on restoring this functionality as a priority.
Posted Oct 14, 2024 - 16:15 BST
Update
We are continuing to work with our infrastructure provider on a resolution to the Box Office App connectivity issues as a priority.

For those who urgently require a solution to print and take in-person payments, then you could consider running occupancy reports (these can be run from the Sales Interface underneath each Event Instance) in place of printing tickets, and taking in-person payments using the long card number (as if you were on the phone).

Please reach out to the Support Team if you need help with these.
Posted Oct 14, 2024 - 14:32 BST
Update
We’re currently in dialogue with our infrastructure provider to continue with the required work to resolve the connectivity issues with the Box Office App. As soon as we have further understanding on the timeline we will provide an update on when we expect this to be resolved. We don’t believe that any attempts to fix the problem locally by attempting to restart or re-install will succeed currently.

For those who are urgently requiring a solution to print and take in-person payments then you could consider running occupancy reports (these can be run from the Sales Interface underneath each Event Instance) in place of printing tickets, and taking in-person payments using the long card number (as if you were on the phone). Please get in touch with us if you need help with these.
Posted Oct 14, 2024 - 13:29 BST
Update
We're still working through the fix to the Box Office App. In this time you may see slowness accessing Local Settings within Spektrix, and your Box Office App may be showing as disconnected, which would prevent you from printing tickets via Spektrix, or taking chip and pin/contactless payments. Spektrix Payments users will be able to take in-person payments still, and print receipts from card terminals, but will be unable to print physical tickets.

If you are experiencing issues, and have the relevant permissions to be able to restart or reinstall the App, you can try do to so, although it may not successfully reconnect at this time.

We will continue to update regularly as we process a complete fix for this issue, and will post here with any further steps or instructions you may need to take as required.
Posted Oct 14, 2024 - 12:32 BST
Update
We are continuing to work on a fix for the Box Office App connectivity problems that some people are experiencing at the moment. You may also see slowness accessing 'Local Settings' from your control panel.

If your App is currently unable to restart we advise waiting a short period of time for an update from us. We can advise further when this is resolved and potential next steps if your App doesn't reconnect automatically.
Posted Oct 14, 2024 - 12:03 BST
Identified
We have identified an issue that has resulted in several users are currently having issues connecting to the Box Office App. This will be impacting the ability to print or take chip and pin payments. Chip and Pin payments for Spektrix Payments users will be unaffected.

We are working on a fix for this currently. In the meantime if your App is currently unable to restart we would advise waiting a short period of time for an update from us. We can advise further when this is resolved and potential next steps if your App doesn't reconnect automatically.
Posted Oct 14, 2024 - 11:50 BST
This incident affected: Spektrix System (UK and Ireland, US and Canada).