Issues with Support Center Form submissions

Incident Report for Spektrix

Resolved

This is now fully resolved - you'll be able to submit forms via our Support Centre as usual.
Posted Feb 10, 2026 - 14:16 UTC

Update

We are continuing to work on a fix for this issue.
Posted Feb 10, 2026 - 12:27 UTC

Identified

We are currently investigating an issue with our service provider that is preventing the submission of Contact Support, Report Requests, Import Requests, Training Requests and Seating Plan Requests through our Support Centre.

Our team is still fully available to help - you can continue to reach us directly by emailing support@spektrix.com and we will process your requests from there as usual.
Posted Feb 10, 2026 - 12:07 UTC
This incident affected: Support Services (Support Centre and support@spektrix.com) and Spektrix System (UK and Ireland, US and Canada, Australia and New Zealand).