Reports of system slowness
Incident Report for Spektrix
Resolved
After a period of continued close monitoring we're confident that there are no issues with the performance of the Spektrix system.
The broader network/internet provider related issues that some have experienced today appear to have resolved now based on the reports we've been receiving from you.
Posted Mar 22, 2024 - 15:02 GMT
Monitoring
The majority of users who had reported issues are now seeing a return to normal speeds.
Our investigation hasn't found any problems with the Spektrix system itself, and we continue to believe based on the nature of the reports we received, that any issues were related to problems with the BT/Openreach network, and only affected those who use a BT/Openreach affiliated ISP.

We are continuing to closely monitor on our side and if there are any further problems we will update here.
Posted Mar 22, 2024 - 13:00 GMT
Investigating
We have received several reports of slowness accessing the Spektrix system and also clients' websites.
We currently don't believe there are any issues directly with our system or infrastructure, but we are investigating further.

We have seen that BT has been having issues in certain locations that matches the locations of clients who have reported slowness - right now we believe this will be the cause of any problems you are experiencing.

If you know you do not use BT as an internet service provider, and are experiencing problems, please do get in touch with as much information as possible to aid our own investigation.
Posted Mar 22, 2024 - 11:47 GMT
This incident affected: Spektrix System (UK and Ireland).