We are confident this issue is now resolved. If you experience any issues with Spektrix or Dotdigital please reach out by email at support@spektrix.com or by phone at +1 (646) 569-9097 | Toll Free: +1 (800) 961-5971. Thank you again for your patience during this period today.
Posted Nov 15, 2024 - 21:49 GMT
Monitoring
Between the hours of 12:30 EST / 5:30 GMT and 2:45 EST / 7:45 GMT integrated emails were failing to send through Dotdigital for clients in United States and Canada. This means any scheduled mailings scheduled during the time above failed to send.
We have now resolved this issue and integrated emails are sending successfully. We will continue to monitor this fix to ensure this resolution remains working.
You can send any failed mailings out again through Spektrix or directly through Dotdigital. If you have any questions or need any support on this please get in touch via phone or email at support@spektrix.com or +1 (646) 569-9097 | Toll Free: +1 (800) 961-5971.
Posted Nov 15, 2024 - 20:24 GMT
Investigating
We're aware of an issue impacting client systems utilizing Dotdigital for sending integrated mailings. We've received reports that emails sent through Dotdigital are not sending properly, as well as severe system slowness and errors popping up when attempting to navigate the Insights & Mailings interface as normal.
We're confident that this is only impacting clients in the US and Canada. We're actively working to isolate the root cause and take steps to resolve these issues.
Posted Nov 15, 2024 - 19:29 GMT
This incident affected: Spektrix System (US and Canada) and dotdigital.