Problems confirming payments online
Incident Report for Spektrix
Resolved
We are happy that any issues confirming payments online has now been resolved.

You may have found that you had some open transactions from the last hour with failed card payments within them. Customers will not have been charged, and the transactions should have timed out by themselves, meaning no further immediate action needs to be taken. All customers should now be able to confirm orders successfully.

If the transaction hasn't timed out, please check your MySagePay portal to confirm if the transaction has gone through or not, and take appropriate action with the customer from there.

If you need any help investigating a particular transaction please contact Support on 020 7183 3586 or support@spektrix.com.

Thanks very much for your patience as we worked quickly to resolve this issue.
Posted 3 months ago. Jul 17, 2019 - 13:12 BST
Monitoring
Hi all,

We have managed to isolate a problem and push a quick fix out to resolve this. We are happy the problem has now been resolved, but will continue to monitor for the next few minutes and provide an update here shortly.

Thanks for your patience.
Posted 3 months ago. Jul 17, 2019 - 12:59 BST
Investigating
We are currently aware of a problem with some customers having difficulties confirming payments online.
We are in discussion with SagePay, our payment service provider, and conducting our own investigations. We will post here with more updates shortly
Posted 3 months ago. Jul 17, 2019 - 12:44 BST
This incident affected: Payments Processing (SagePay).