Thank you for your patience whilst we looked into and resolved the system slowness that some users were experiencing earlier today. We'll continue to monitor the system as usual and if you have any questions or need any support please reach out to support@spektrix.com or via +44 (0)20 7183 3586, +1 (646) 569-9097 or Toll Free at +1 (800) 961-5971
Posted Mar 13, 2025 - 16:44 GMT
Monitoring
Since our fix, we've seen system speeds return to normal. We'll continue to monitor closely. Thank you for your patience whilst we looked into this - as ever, if you have any questions or need any support, please reach out to support@spektrix.com.
Posted Mar 13, 2025 - 14:59 GMT
Identified
We're identified and are actively working on system slowness which started around 14:08 GMT / 10:08am EST where some users may be experiencing slowness on clicks within the interface. We'll keep you updated as we progress.
Posted Mar 13, 2025 - 14:50 GMT
This incident affected: Spektrix System (UK and Ireland, US and Canada).