All payments down between c. 10:58-11:04 BST

Incident Report for Spektrix

Resolved

We're happy that the issue affecting payments has been completely resolved. We will continue to monitor all systems and do let us know if you experience any further issues.

To confirm, between approximately 10:58-11:04 BST no payments would have been able to have confirmed and customers would have experienced an error message when attempting payment. Any retries from after c. 11:04 should have been successful.

Thanks for your understanding as we resolved this one.
Posted Apr 03, 2024 - 11:23 BST

Monitoring

We've been able to identify and fix the issue causing payments to fail across all channels.
We'll continue to monitor but we're happy that everything is back up and running.
Posted Apr 03, 2024 - 11:06 BST

Investigating

We are aware of an issue causing payments to fail across all channels currently.

We're working to resolve this asap and will provide further updates as soon as we have them
Posted Apr 03, 2024 - 10:59 BST
This incident affected: Payments Processing (Opayo (formerly SagePay), Worldpay (formerly Vantiv), Authorize.Net, Moneris, PayPal).