Errors and System Slowness
Incident Report for Spektrix
Resolved
We've been monitoring the system and believe these issues are now resolved. We apologize for any inconvenience, and if you have further questions, don't hesitate to contact our Support Team.
Posted 2 months ago. Aug 15, 2019 - 18:37 BST
Monitoring
We believe system speeds are now back to normal and people are no longer seeing refreshes of the page they are on. We will continue to monitor the issue but you should be able to use the system as normal now.
Posted 2 months ago. Aug 15, 2019 - 18:06 BST
Update
We are still investigating solutions to the issue with pages 'refreshing' during transactions. In addition to this, we are aware some people may be experiencing some slowness and seeing clicks not completing.

We will update here shortly.
Posted 2 months ago. Aug 15, 2019 - 17:54 BST
Identified
Hi everyone,

We have received more reports of 'refreshes' of the screen when performing transactions, so we don't believe the issue is resolved yet.

We are aware of the problem and are finishing diagnosis, so we should be able to update very soon with more details on when this issue will be resolved.

Thanks for your patience so far.
Posted 2 months ago. Aug 15, 2019 - 17:36 BST
Update
We're continuing to investigate the causes of the behaviour that was experienced, but you should find that using the Interface and confirming payments are now acting as expected.
Posted 2 months ago. Aug 15, 2019 - 17:31 BST
Update
We are continuing to investigate this issue.
Posted 2 months ago. Aug 15, 2019 - 17:20 BST
Investigating
We've identified some strange behaviour when confirming transactions and navigating when in your Sales Interfaces. We're investigating this and will update you as soon as we know more! Thanks for bearing with us.
Posted 2 months ago. Aug 15, 2019 - 17:19 BST
This incident affected: Spektrix System (Spektrix System - UK/IE, Spektrix System - US/CAN).