We haven't seen any further instances of the error screens and system slowness reported earlier. We're confident that the issue is solved. If you're experiencing any further issues, please do get in touch with our support team via support@spektrix.com or give us a call:
UK and Ireland: +44 (0)20 7183 3586
USA and Canada: +1 (646) 569-9097
Thanks for your patience while we worked to resolve this.
Posted Sep 23, 2026 - 11:33 UTC
Monitoring
We identified an issue that will have caused system slowness and error screens while navigating the Spektrix system from 11:50am to 12:12pm UTC. We believe we have solved the cause of this issue and you should no longer see these error screens and system slowness. We're continuing to monitor closely and will update here once we are confident the issue is solved.
Posted Sep 23, 2026 - 11:14 UTC
This incident affected: Spektrix System (UK and Ireland, US and Canada).