Support phone line degraded performance.

Incident Report for Spektrix

Resolved

Thank you for your patience and understanding whilst we investigated the connectivity of our Support phone lines. All systems are now fully operational.
Posted May 30, 2026 - 08:56 UTC

Investigating

We have identified and are investigating some connectivity issues with our Support phone lines. Email services are working as normal, so we encourage writing in to support@spektrix.com to get in touch with our Support Team in the meantime.

We will continue to update here as we know more.
Posted May 29, 2026 - 19:21 UTC
This incident affected: Support Services (Phone Service - UK/Ireland, Phone Service - North America).