Issues processing payments
Incident Report for Spektrix
Resolved
We are confident that payments are continuing to process successfully, so are stepping away from active monitoring.

If you require further support and assistance following this, please reach out to the team on support@spektrix.com
Posted Jul 14, 2024 - 19:04 BST
Monitoring
We have continued to monitor the impact of our fix, and are happy that payments continue to process successfully.

To recap, there were issues processing card payments between 17:05 BST / 12:05 EDT and 18:30 / 13:30 EDT. This affected payments online and in the Spektrix interfaces, but Chip/Chip & Pin transactions would have been successful in this time.

If you require further support and assistance following this, please reach out to the team on support@spektrix.com
Posted Jul 14, 2024 - 18:44 BST
Identified
We have implemented a fix, and believe that card payments are now processing successfully.

We are monitoring this closely to ensure payments continue to process successfully.
Posted Jul 14, 2024 - 18:34 BST
Update
We are continuing to investigate this as a priority. We believe that this is only affecting 'card' payments, and that Chip/Chip & Pin payments will still be successful.
Posted Jul 14, 2024 - 18:19 BST
Update
To further clarify the behaviour we're seeing here, you may be seeing a "502 bad gateway" message when attempting payments, or the payment screen where you enter card details may appear blank, leaving you unable to enter information.
Posted Jul 14, 2024 - 18:00 BST
Investigating
We are currently investigating issues processing card payments, both online and in the Spektrix interface.

We are investigating as a priority and will keep you updated.
Posted Jul 14, 2024 - 17:57 BST
This incident affected: Payments Processing (Opayo (formerly SagePay), Worldpay (formerly Vantiv), Authorize.Net, Moneris) and Spektrix System (UK and Ireland, US and Canada).