Issue with taking payments for Canadian users
Incident Report for Spektrix
Resolved
On 3 September at 7:58pm EDT Moneris were able to resolve the Gateway issues and return transaction processing to normal. You may have experienced some transaction slowness while their systems catch up, but there should no longer be transaction time-outs.

If you require any further support on this, please reach out on support@spektrix.com or call us on +1 (646) 569-9097
Posted Sep 04, 2023 - 09:28 BST
Update
Moneris are continuing to work on a solution for the issue with payments for users in Canada. Users who are impacted may experience slowness or intermittent timeouts when processing transactions.
Posted Sep 03, 2023 - 15:16 BST
Update
Moneris are continuing to work on restoring normal payment services for users in Canada. They will continue to update the status of this on their Status Page: https://www.moneris.com/servicestatus
Posted Sep 03, 2023 - 13:07 BST
Identified
At around 6:42am BST / 1:42am EDT we became aware of an issue preventing users in Canada from taking successful payments. This issue has been identified by Moneris, one of our payment providers. They are working to restore services and are providing updates on their status page: https://www.moneris.com/servicestatus
Posted Sep 03, 2023 - 10:52 BST
This incident affected: Payments Processing (Moneris).