Reports of system slowness
Incident Report for Spektrix
Resolved
We're confident now that all issues are resolved and the Spektrix system is operating as normal following on from our infrastructure provider declaring everything to be resolved at their side.
Posted Jul 05, 2023 - 20:17 BST
Monitoring
We believe after communicating with our infrastructure provider that the slowness issues should now be resolved.
We are continuing to monitor the system and keep track of any reports of further issues so please let us know if you continue to encounter slowness on your system.
Posted Jul 05, 2023 - 17:48 BST
Investigating
We're currently investigating reports of system slowness. This seems to be affecting customers online as well as the Spektrix system.

We believe this is due to issues with our third party infrastructure provider, and are coordinating with them to resolve this as soon as possible.

You should be able to complete system actions as normal, but with some delays.
Posted Jul 05, 2023 - 16:09 BST
This incident affected: Spektrix System (UK and Ireland).