System slowness and error screens

Incident Report for Spektrix

Resolved

After closely monitoring the system we are confident everything has been resolved and all system speeds have remained stable since 10:30 UTC (11:30 BST).

If you continue to experience issues please contact us in the usual way.
Posted Sep 25, 2026 - 11:06 UTC

Monitoring

The action we have taken to fix the issue with system slowness has resolved the problem.

We will continue to monitor the issue and update here if anything changes.
Posted Sep 25, 2026 - 10:34 UTC

Identified

We've identified an issue causing some system slowness.
We've already taken some corrective action so this is in the process of being resolved.
We'll provide further updates very shortly.
Posted Sep 25, 2026 - 10:32 UTC
This incident affected: Spektrix System (UK and Ireland, US and Canada, Australia and New Zealand).