System Slowness for some users

Incident Report for Spektrix

Resolved

We're happy now to mark the overall system slowness issues are fully resolved. We will continue to monitor as usual and will alert here if there are any further issues.
Thanks for your understanding as we worked to resolve this.
Posted Mar 18, 2025 - 19:55 GMT

Monitoring

We are seeing that system speeds are now back up to normal. We will continue to monitor this over the rest of the evening and report back once we're happy everything is fully resolved.
Posted Mar 18, 2025 - 19:24 GMT

Update

We appreciate your patience whilst we continue to work on a fix for this issue. We have started to see improvement in system performance. We will continue to provide further updates on this.
Posted Mar 18, 2025 - 19:18 GMT

Identified

We're aware that some of you are experiencing intermittent system slowness similar to earlier today starting around 18:00GMT / 14:00pm EDT. We have already identified the cause of this issue and are taking steps to mitigate this. We'll keep you updated as we progress.
Posted Mar 18, 2025 - 18:30 GMT
This incident affected: Spektrix System (UK and Ireland, US and Canada).