Issues with reports and lists not running
Incident Report for Spektrix
Resolved
We are happy this issue with reports and lists running slowly was successfully resolved on Friday.
Posted Sep 04, 2023 - 08:30 BST
Monitoring
For the majority of cases, reports and customer lists are running successfully. We are still undertaking monitoring and root cause analysis work on this and will update once we are confident the issue is resolved or if there are any further delays.
Posted Sep 01, 2023 - 18:00 BST
Identified
We are seeing improvements with report speeds now, however there may still be some delays with these taking place.

We are continuing to work on this issue and will update further shortly.
Posted Sep 01, 2023 - 17:33 BST
Investigating
We have identified further issues with reports and lists not running following on from the problems earlier in the day. Running reports will not complete currently and continue to look as if they are generating.
We are investigating this as a high priority and will continue to update with more news shortly.
Posted Sep 01, 2023 - 16:57 BST
This incident affected: Spektrix System (UK and Ireland, US and Canada).