Issues with YesPay payment services
Incident Report for Spektrix
Resolved
YesPay payments have been successfully confirming since around 3pm this afternoon, so we are resolving this incident. Thank you for your patience.
Posted Nov 14, 2019 - 19:33 GMT
Monitoring
YesPay transactions seem to be processing successfully now. We are continuing to monitor this issue, but please do contact us if you experience any further issues processing payments with YesPay.
Posted Nov 14, 2019 - 17:29 GMT
Update
YesPay are making progress in resolving the current issues with phone and web payments. However, unfortunately payments are still not processing correctly. You may now be seeing a different error message than before - we are helping YesPay to investigate this and will keep you updated with our progress.
Posted Nov 14, 2019 - 14:50 GMT
Update
We are still liaising with YesPay to try to resolve their issues with phone and web payments. Many thanks for bearing with us whilst we get to the bottom of what's happening. We'll keep you updated with more news as soon as we have it.
Posted Nov 14, 2019 - 12:25 GMT
Update
We are continuing to investigate this issue.
Posted Nov 14, 2019 - 10:28 GMT
Update
Unfortunately, the issue with phone and web YesPay payments was not resolved overnight.
We are still trying to work with the YesPay/WorldPay team so they can resolve their issues.

At the moment, if you take payments with YesPay, you will not have been able to take phone or web payments since around 15:30 yesterday (13th November). This is still the case. Chip and Pin transactions are unaffected and working as normal.

We will update you when we have more information from YesPay, or, if we have no more updates, within the next hour. In the meantime please do contact the Support Team to see if there is an alternative payment method we can work with you to set up. For example, with the help of your finance team it may be possible to set up a PayPal integration fairly quickly to at least allow you to confirm web payments.
Posted Nov 14, 2019 - 10:16 GMT
Update
We're working with YesPay to resolve this as swiftly as possible. We'll keep you regularly updated here. Thanks again for your continued patience.
Posted Nov 14, 2019 - 10:15 GMT
Update
We're still working with YesPay to find the source of these issues. We will provide an update at 10:00GMT as to how the investigation is progressing.
Posted Nov 13, 2019 - 21:06 GMT
Update
We're still working with YesPay to find the source of these issues. Please bear with us and we'll let you know when we have further news.
Posted Nov 13, 2019 - 17:47 GMT
Investigating
We've received some reports of further issues processing payments through YesPay - we're investigating this and will let you know as soon as we get any more information.
Posted Nov 13, 2019 - 16:08 GMT
Monitoring
All our YesPay clients' payments have been processing as expected now, but we'll keep monitoring this just in case. Thanks for bearing with us.
Posted Nov 13, 2019 - 14:04 GMT
Investigating
We are currently investigating an issue with payment processing for our clients using YesPay. We are liaising with YesPay now and will update shortly.
Posted Nov 13, 2019 - 11:50 GMT
This incident affected: Payments Processing (Moneris).