Slowness running reports and other jobs
Incident Report for Spektrix
Resolved
We're happy now this issue has fully resolved and all reports and jobs are back to normal speeds. Thanks for your patience as we worked on this one.
Posted Dec 01, 2023 - 16:55 GMT
Monitoring
Our fix has seen all jobs return to normal speeds now and are completing successfully. We are continuing to monitor this and will update further when we are happy the issue is fully resolved.
Posted Dec 01, 2023 - 16:42 GMT
Update
We're seeing some initial improvements to the slowness with reports and jobs and are continuing to work to improve this further as we work on the fix for this. We'll continue to update on our work to resolve this here.
Posted Dec 01, 2023 - 16:35 GMT
Identified
We believe we have identified the cause of this issue and are currently working through the best way to resolve it. As well as reports currently other system jobs, such as autotags, overlay updates, and integrated mailings will also be delayed. We still expect these to complete but after a longer than usual run time.
Posted Dec 01, 2023 - 16:24 GMT
Investigating
We're investigating some slower than expected report and customer list running times currently. Right now we're seeing these have some delays but these are currently completing. If you are waiting for a job to finish it should complete so there is no need to run anything again.

We're looking into the cause of these delays and will update further with more information shortly.
Posted Dec 01, 2023 - 16:10 GMT
This incident affected: Spektrix System (UK and Ireland, US and Canada).