Issue with sending system emails

Incident Report for Spektrix

Resolved

We've been able to fix the underlying issue and believe all system emails should be sending as expected now so we are marking this as resolved. We will continue to monitor as usual. If you have any questions, please do reach out to us at support@spektrix.com or on +44 (0)20 7183 3586 | +1 (646) 569-9097 | Toll Free: +1 (800) 961-5971.
Posted Feb 05, 2026 - 17:18 UTC

Monitoring

We've identified the cause of the issues with system emails and have put a fix in place. You should start seeing system emails sending again, and emails that were previously unsent should now complete.

We'll continue to monitor the situation.
Posted Feb 05, 2026 - 17:08 UTC

Investigating

We've seen that system emails may not be sending. these will include new account, password reset, confirmation emails gift voucher purchases and scheduled reports as of around 2:30pm UTC.

We're looking into the cause of this and will update here shortly.
Posted Feb 05, 2026 - 17:03 UTC
This incident affected: Spektrix System (UK and Ireland, US and Canada, Australia and New Zealand).