Some donations may not be visible under customer profile
Incident Report for Spektrix
Resolved
We have been able now to fix the issue with the behaviour above and all donation history on a customer profile is now fully visible again and ordering correctly. We will continue to monitor the situation here but mark this as a resolved status page. If there are any recurrences we will communicate this as required.
Posted May 18, 2023 - 16:43 BST
Update
We have resolved the issue of error screens when clicking into the Orders tab on a Customer Record, and are confident that this will not reoccur.

We are continuing to work on a resolution to the missing donation information, and will update you on this tomorrow.
Posted May 17, 2023 - 16:46 BST
Update
We released a potential fix to this in the last half hour, but since implementing this we have noticed that this has caused some error screens when accessing the Orders tab on a Customer record. We have identified the cause of this and are implementing a fix for this now. We will update you once we have completed this and are confident it is resolved.

We will continue working on a resolution to the missing donations information, and will update you on this tomorrow.
Posted May 17, 2023 - 16:32 BST
Identified
The cause of the issue has been identified and we are taking steps to resolve it. We will continue to keep you updated as we work towards a resolution.
Posted May 16, 2023 - 17:39 BST
Investigating
We are currently investigating an issue that may cause you to only see partial donation history under the donations tab in the customer record. This issue is only impacting the donations tab in the customer record. All reports, customer lists, and segmentation using donation data are fully operational. We are working to resolve this issue now and will update you accordingly.
Posted May 15, 2023 - 22:28 BST
This incident affected: Spektrix System (UK and Ireland, US and Canada).