Issues with Dotdigital emails sending
Incident Report for Spektrix
Resolved
We’ve been monitoring this alongside dotdigital for some time now, and we are confident that the issue is now fully resolved. Thank you for your patience and understanding whilst we worked to resolve the cause of this.

If you need any further support on this please don't hesitate to contact us by opening up a new request via support@spektrix.com or calling us on 020 7183 3586.
Posted Apr 27, 2023 - 14:43 BST
Monitoring
Dotdigital have let us know that they've managed to identify the cause of these emails failing to send, and have implemented a fix. We have seen an improvement since they implemented this fix, and will be closely monitoring the system to ensure that this continues.

If you need any further support please don't hesitate to contact us by opening up a new request via support@spektrix.com or calling us on 020 7183 3586.
Posted Apr 27, 2023 - 12:16 BST
Update
We continue to see some Dotdigital emails failing to send. While the majority of emails are sending successfully, we know that some of you are seeing multiple attempts to send emails fail. We understand how frustrating this is, and we are working with Dotdigital on understanding and resolving the cause of this issue.

If you have any time sensitive communications to send, we advise you to check Dotdigital's Sent list to confirm whether the mailing has sent. If it failed, please retry sending this email.

Dotdigital is working on resolving this issue as a priority. They are making progress in identifying and working towards a solution. We will provide further updates as soon as we have them.
Posted Apr 27, 2023 - 11:15 BST
Update
From around 09:00 BST / 04:00 EDT we have experienced some dotdigital emails failing to send. While the majority of emails are sending successfully, we know that some of you are seeing multiple attempts to send emails fail. We understand how frustrating this is, and we are working with dotdigital on understanding and resolving the cause of these issues.

If you have any time sensitive communications to send, we would advise you to check dotdigital to confirm whether the mailing has sent. If it failed, please retry sending this email.

We will update you on this tomorrow morning.
Posted Apr 26, 2023 - 18:12 BST
Update
We are still working with Dotdigital on understanding the issues some users are experiencing when attempting to send emails through Dotdigital. The vast majority of emails are being successfully sent, however this is sometimes taking multiple attempts to send.
We understand the frustration involved, and are working closely with Dotdigital to understand the cause of the issue and will provide further updates in due course.

If you have any time sensitive communications to send, we would still advise you to continue to retry sending your email after checking within Dotdigital to confirm the mailing has failed to send and to avoid multiple sends.
Posted Apr 26, 2023 - 15:58 BST
Update
We are currently still working on understanding the issue experienced by some when attempting to send emails through Dotdigital. The vast majority of emails are being successfully sent, however this is sometimes taking multiple attempts to send.
We understand the frustration involved, and are working closely with Dotdigital to understand the cause of the issue and will provide further updates in due course.

If you have any time sensitive communications to send, we would still advise you to continue to retry sending your email after checking within Dotdigital to confirm the mailing has failed to send and to avoid multiple sends.
Posted Apr 26, 2023 - 13:44 BST
Update
We're still working on understanding the issues some of your are seeing when sending emails via Dotdigital. Whilst the majority of emails are being sent, we know that some of you are seeing multiple attempts to send emails fail and we completely understand how frustrating this is.

If you have any time sensitive communications to send, our current advice is to continue to retry sending your email after checking within Dotdigital to confirm the mailing has failed to send.

We are still working closely with Dotdigital to understand the cause of the issue here and will provide further updates in due course.
Posted Apr 26, 2023 - 12:26 BST
Update
We're still working to understand this problem with mailings failing to send.

We are seeing that retries are often successful and that not every email is failing. We are working to establish the cause of this and will continue to update here as we work on this with Dotdigital.
Posted Apr 26, 2023 - 11:31 BST
Update
We're continuing to look at this with Dotdigital to understand a cause. It looks like in the last 20 minutes all mailings have sent successfully but as we are still looking into what the underlying issues are we aren't yet able to say that this issue is resolved. We will continue to update here as we know more.
Posted Apr 26, 2023 - 10:48 BST
Investigating
We're investigating issues with Dotdigital emails not sending and working with them to resolve this.
We think this may have started at 9am BST with a small number of failures and some 'false flag' errors where mailings did send. From 10am BST we have started seeing a much larger number of failures.
We're talking with Dotdigital and will provide further updates on this as we have them
Posted Apr 26, 2023 - 10:32 BST
This incident affected: dotdigital.