We believe that this issue is only affecting users using Outlook for their Mailbox provider and this seems to correspond to Microsoft 365's status page where they have reported issues in relation to business or enterprise accounts.
This may be impacting the delivery of Spektrix scheduled reports. If you are not using Microsoft 365 as your mailbox provider, please get in touch with us with the name of your affected Report Schedule.
To re-run reports in the meantime, you can tick to run them on demand, and run the reports from the Partner Companies Interface. Please reach out to us if you continue to get errors when trying this solution.
Posted Sep 01, 2026 - 09:27 UTC
Investigating
We’re aware of an issue with report schedules not delivering over the last few days. We’re currently investigating the cause and will provide an update as soon as possible.
For the time being, if you tick to run them as a schedule, you can run reports from the Partner Companies Interface instead to re-run these reports. Please reach out to us if you continue to get errors when trying this solution.
Posted Sep 01, 2026 - 08:56 UTC
This incident affects: Spektrix System (UK and Ireland, US and Canada, Australia and New Zealand).