Vantiv Payment Processing experiencing issues affect some North American Clients
Incident Report for Spektrix
Resolved
Vantiv has since reported that the issue affecting payment processing has been resolved and payments should now go through. If you continue to experience issues with processing payments, please contact Spektrix Support.
Posted Mar 07, 2018 - 19:59 GMT
Investigating
Vantiv is currently experiencing some issues that are impacting processing for some North American clients. As updates become available, we will provide them here through the status page.
Posted Mar 07, 2018 - 19:13 GMT
This incident affected: Payments Processing (Worldpay (formerly Vantiv)).