Spektrix system inaccessible
Incident Report for Spektrix
Resolved
Between 12:15 and 1:40 PM (BST) today Spektrix was inaccessible. This affected system users, customers booking tickets online and our APIs.

Users attempting to access Spektrix during this time saw a 'Connection Timed Out' error or similar message. Customers were not able to complete a booking online via your website.

We identified the cause of the problem shortly after the outage began. Our team developed a fix which was rolled out to the Spektrix system at 1:29 and system access was fully restored by 1:40 PM. After that time, users and customers could access Spektrix as normal and our APIs functioned as usual. We are confident that the system is functioning as normal.

During the outage, scheduled Dotdigital emails, reports and customer lists will have continued to run successfully. Open transactions, or reservations which were due to time out will now have timed out.

We apologise again for the disruption, and thank you for your patience whilst we looked into this. If you require any further assistance, please reach out at support@spektrix.com or call us on +44 (0)20 7183 3586
Posted Oct 09, 2023 - 14:59 BST
Monitoring
Further investigations confirms that report schedules and customer list schedules will have continued to run successfully whilst the system was down. Open transactions, or reservations which were due to time out, will now begin timing out.

We are continuing to monitor the system closely and are confident that all system areas are functional.
Posted Oct 09, 2023 - 13:56 BST
Update
We have now fully implemented the fix across the Spektrix system and our monitoring and testing shows that this has been successful. You should now be able to log in to your system, and iframes and the Spektrix API are now accessible again.

We are confirming whether there are any further implications of the system having been down, and will update on this shortly.
Posted Oct 09, 2023 - 13:44 BST
Update
The initial part of the fix has seen positive improvements, with some system access being restored. We're now working on ensuring we can apply this more widely across the Spektrix system.
Posted Oct 09, 2023 - 13:29 BST
Update
We are implementing a fix that we believe will have a positive impact on the system, however we aren't yet able to guarantee this fix will work and we may need to deploy further changes afterwards.

We are aware of the impact that this will be having on you, and are working to restore access as soon as we are able.
Posted Oct 09, 2023 - 13:09 BST
Update
Currently, the entire Spektrix system (including the iFrames and the Spektrix API) is unavailable. You may be seeing a "Connection Timed Out" error page.

We are investigating this as a priority and working to restore access to the system as soon as possible. We will update further as soon as we are able.
Posted Oct 09, 2023 - 12:40 BST
Update
When attempting to log into or navigate around the Spektrix system, you may see an error page that says the connection has timed out.

We are working on restoring access to the system as a priority.
Posted Oct 09, 2023 - 12:30 BST
Identified
We are aware the the Spektrix system is currently inaccessible. We have identified the cause of this and are working on resolving this as a priority.
Posted Oct 09, 2023 - 12:22 BST
This incident affected: Spektrix System (UK and Ireland, US and Canada).