Reports Running Slowly

Incident Report for Spektrix

Resolved

Report speeds should now be back to normal. Apologies to those of you who had trouble running reports in the last 30 minutes or so, we should be running at full speed again.
Posted Apr 04, 2019 - 16:33 BST

Investigating

Some of you will be experiencing reports running slower than usual. We are working to make sure things get back to full speed as soon as possible, please bear with us whilst we resolve the issue.
Posted Apr 04, 2019 - 16:18 BST
This incident affected: Spektrix System (UK and Ireland, US and Canada).