Our team is continuing to see Spektrix systems operate as normal across North America, the UK, and Ireland and any system slowness should be returning to normal. Our team will be marking this incident as resolved.
As always, we will continue to monitor client systems to ensure that systems are running as expected. Thank you again for your patience.
Posted Jun 12, 2025 - 22:25 BST
Monitoring
We have seen improvement in Spektrix system response times and have seen an improvement noted on our partner's status page: https://www.cloudflarestatus.com/
Our teams will continue to monitor all client systems to ensure that things are running as expected.
Posted Jun 12, 2025 - 22:03 BST
Identified
We have identified an outage with a third party provider which is impacting Spektrix systems across the UK and North America - This page can be found here: https://www.cloudflarestatus.com/
During this time you will continue to experience intermittent system slowness when loading between interfaces or performing regular activity in your Spektrix system.
We will continue to monitor our partner's status page for any updates and will update our clients as we see changes or updates.
Posted Jun 12, 2025 - 21:39 BST
Investigating
We are aware of intermittent system slowness affecting clients. We are still working to investigate the cause of the issue and the number of clients that are affected, but will update as we know more.
During this time, you may experience longer times between clicks when navigating your system.
Thank you for your patience.
Posted Jun 12, 2025 - 21:26 BST
This incident affected: Spektrix System (UK and Ireland, US and Canada).