Payments not available via Adyen Gateway

Incident Report for Spektrix

Resolved

This incident has been resolved. Adyen is noting that payment processing has fully recovered.
Posted Apr 21, 2025 - 19:43 BST

Monitoring

Adyen has provided an update that payment processing has fully recovered since 18:39 GMT /13:39 ET. We will continue to monitor. For real time updates, you can subscribe to Adyen's status page: https://status.adyen.com/
Posted Apr 21, 2025 - 19:31 BST

Investigating

We're aware that Adyen is experiencing degraded performance that started today around 17:55 GMT / 12:55 EDT. Those who use Spektrix Payments as their payment provider may be affected and be unable to take payments. We suspect this may affect all Spektrix clients on Adyen including those in the US, CA, UK and Northern Ireland. For real time updates, you can subscribe to Adyen's status page: https://status.adyen.com/
Posted Apr 21, 2025 - 18:39 BST
This incident affected: Payments Processing (Spektrix Payments (Adyen)).