Some clients experiencing system slowness
Incident Report for Spektrix
Resolved
We're happy all system speeds have returned to expected levels now. We are continuing to monitor but the fix we have implemented is in place and we can see response times are back to normal.
Posted Oct 01, 2024 - 23:59 BST
Monitoring
We believe we have identified the cause of this issue and are implementing a fix to improve system speeds.
The slowness will also be impacting websites, and you may notice queues trigger briefly before clearing, as well as slow clicks around your website.

Systems speeds have started to return to normal following the implementation of the fix. Some clients may have experienced slowness in their Spektrix system and on their website between 23:00 BST / 17:00 EDT and 23:55 BST / 17:55 EDT.

We are continuing to monitor this closely.
Posted Oct 01, 2024 - 23:01 BST
This incident affected: Spektrix System (US and Canada).