System slowness and error pages

Incident Report for Spektrix

Resolved

We are now confident that the system slowness and error screens have been resolved. We will continue to monitor as usual.
Posted Mar 27, 2025 - 18:07 GMT

Monitoring

A fix has been implemented and we will continue to monitor to ensure systems are running smoothly.

If you encounter any system slowness or error screens please contact support@spektrix.com or call us at +44 (0)20 7183 3586 for UK and Ireland from 9am - 9pm Sunday - Monday. For the USA and Canada you can call +1 (646) 569-9097 or Toll Free: +1 (800) 961-5971 Monday - Friday 10am - 9pm EST.
Posted Mar 27, 2025 - 18:07 GMT

Identified

Hi there,

We are aware that for some users there has been some intermittent system slowness and some of you have also experienced error pages when clicking within the system.

We identified this issue at around 16:15 GMT / 12:15 EST and were able to take immediate steps to resolve this. This resulted in improvements but there have been further issues since this time that have caused further error pages to occur.

We are going through the resolution steps to fix this now and will update further as we progress through this work.
Posted Mar 27, 2025 - 17:29 GMT
This incident affected: Spektrix System (UK and Ireland, US and Canada).