Sage Pay are currently experiencing issues with MySagePay
Incident Report for Spektrix
Resolved
Sage Pay have now resolved their issues with users connecting to their MySagePay portal.
Posted Apr 09, 2018 - 12:55 BST
Identified
Sage Pay are currently experiencing issues with their MySagePay portal which may prevent some users from logging in to their account. Investigations are underway and we will update once they have resolved. You can also keep track of live updates by visiting their twitter page - https://twitter.com/SagePaySupport
Posted Apr 09, 2018 - 12:36 BST
This incident affected: Payments Processing (Opayo (formerly SagePay)).