Slowness with system jobs
Incident Report for Spektrix
Resolved
After a period of monitoring we can see that there have been no further delays with the running of system jobs (such as reports and customer lists) for the past 2 hours, so we are going to mark this issue as resolved.
We will continue to closely monitor the system and will let you know if there are any further problems.
Posted Sep 08, 2023 - 16:29 BST
Monitoring
We're confident that the current level of impact is minimal and that for the vast majority of cases, reports are running as normal, as are other system jobs such as customer lists, mailings and bulk updates.
We're continuing to monitor this and are in conversations with our infrastructure provider to get further information on the root cause of the issue.
We will update here if there are any changes in impact and when we are happy the issue is fully resolved.
Posted Sep 08, 2023 - 14:08 BST
Update
We are still investigating the causes of this issue.

The current impact is that all bulk-update type jobs should now run normally with no delays.
Reports and customer lists will generally run with no delays, however intermittently you may find that a report you run will take 1-2 minutes longer than it would normally.

We will continue to provide further updates on this.
Posted Sep 08, 2023 - 13:39 BST
Investigating
We are investigating issues with jobs in the system being slow to run. These include running reports, customer lists, and performing bulk activities such as bulk adding tags or updating overlays.

These tasks are all currently completing but taking longer than expected to do so. We would currently advise not to 're-run' a task or job and instead wait for the current one to complete.

We will provide further updates on this shortly.
Posted Sep 08, 2023 - 13:07 BST
This incident affected: Spektrix System (UK and Ireland, US and Canada).