SagePay payments
Incident Report for Spektrix
Resolved
Payments have been processing as normal for a couple hours now, so we're marking this issue 'resolved.' Have a great evening everyone!
Posted Mar 07, 2018 - 17:35 GMT
Monitoring
Sage Pay have reported that they've resolved the payments issue at their end, so you should be able to process payments as normal now. We'll keep monitoring this for now.
Posted Mar 07, 2018 - 15:18 GMT
Update
We're seeing some problems with SagePay payments confirming - some, but not all, will be affected. SagePay are aware of the issue and working on it - we will keep you updated with progress.
Posted Mar 07, 2018 - 15:03 GMT
Investigating
Some SagePay clients might be seeing some issues with payments - we are investigating and will update you as soon as possible. You'll still be able to see the failed payments in mysagepay.
Posted Mar 07, 2018 - 14:51 GMT
This incident affected: Payments Processing (Opayo (formerly SagePay)).