Outage of Spektrix Systems
Incident Report for Spektrix
Resolved
We can report that the system issues experienced earlier are now resolved. If you have any questions about this, please don't hesitate to get in touch with the team at support@spektrix.com. Thank you so much for your patience whilst we resolved the issue.
Posted Apr 30, 2021 - 17:01 BST
Update
We are continuing to monitor the system following the earlier issues.
Posted Apr 30, 2021 - 16:42 BST
Monitoring
We have fixed this issue and don't believe users and customers should be affected from now on. We will continue to monitor the system and provide further details where necessary.
Posted Apr 30, 2021 - 16:12 BST
Identified
At 15:55 BST we experienced an outage across multiple Spektrix systems which prevented access to the software for staff and for customers online.

We have identified the cause and are continuing to monitor things.

You may still encounter issues when trying to access Spektrix. If you do, trying to refresh your browser might help you be able to login.
Posted Apr 30, 2021 - 16:08 BST
This incident affected: Spektrix System (UK and Ireland, US and Canada).