Issues with Support Phones
Incident Report for Spektrix
Resolved
Support calls for North American clients should be working as normal again. Sorry if anyone had any trouble getting in touch with us.
Posted Apr 14, 2018 - 14:41 BST
Investigating
We are currently experiencing issues with North American Support phones. If you need to get in touch with us, please send us an email at support@spektrix.com.

We are investigating this, and will update you as soon as we know more!
Posted Apr 14, 2018 - 00:52 BST
This incident affected: Support Services (Phone Service - North America).