North America - limited phone support
Incident Report for Spektrix
Resolved
We are confident that our phone and internet network is now working and stable again, and are closing this issue. Apologies again for any inconvenience caused if you couldn't get through to us on the phones yesterday.
Posted Oct 11, 2018 - 19:41 BST
Monitoring
The phone connectivity issues have been resolved in our New York office. We will continue to monitor our phone systems and provide updates throughout the day if necessary.
Posted Oct 11, 2018 - 15:13 BST
Investigating
We are currently experiencing phone connectivity issues in our New York office. While we work to diagnose the cause of the issue, we'll continue to monitor support tickets and respond as quickly as we are able.
Posted Oct 10, 2018 - 19:04 BST
This incident affected: Support Services (Phone Service - North America).