System Slowness
Incident Report for Spektrix
Resolved
We're happy this has now been resolved, but if you do experience any more slowness or other issues with the system please do contact us on 020 7183 3586 or support@spektrix.com.
Posted Jul 01, 2020 - 11:50 BST
Monitoring
We look to have found the cause for this slowness and have put a fix in place. We will continue monitoring to see if the speeds remain stable.
Posted Jul 01, 2020 - 11:31 BST
Investigating
We're investigating reports of system slowness across some systems and websites.
We will update soon when we have more information.
Posted Jul 01, 2020 - 11:03 BST
This incident affected: Spektrix System (UK and Ireland).