Brief System Slowness

Incident Report for Spektrix

Resolved

We can confirm all systems are running as expected again. If you are experiencing any issues please don't hesitate to get in touch, and we will continue to monitor on our side.
Posted Jul 18, 2025 - 11:46 BST

Monitoring

You may have experienced a brief period of system slowness or error pages for the last few minutes.
This should now be resolved - we're continuing to monitor all systems and will update further if required.
Posted Jul 18, 2025 - 11:11 BST
This incident affected: Spektrix System (UK and Ireland).