Removing TLS 1.1 Support on April 30th
Incident Report for Spektrix
Resolved
This incident has been resolved.
Posted Apr 19, 2018 - 17:57 BST
Identified
In order to maintain our Level 1 PCI compliance status, and to stay in line with improvements in online security, on the 30th April we will be disabling payment support for computers and browsers that aren’t using the most up to date security protocol, TLS 1.2.

From the 30th April, the minimum software requirement for PCs will be Windows 7, and the minimum browser requirement will be Internet Explorer 9. This will affect customers online as well as Spektrix system users, who will no longer be able to reach payment pages if they don’t meet the minimum TLS requirement.

More information can be found here:
https://support.spektrix.com/hc/en-us/articles/360001923591-Removing-TLS-1-1-Support
Posted Apr 19, 2018 - 10:18 BST
This incident affected: Payments Processing (Opayo (formerly SagePay), Worldpay (formerly Vantiv), Authorize.Net, Moneris, PayPal).