Problems taking payments
Incident Report for Spektrix
Resolved
Payments are successfully confirming and should remain stable.

We're sorry for the disruption - thanks for bearing with us while we looked into the issue.
Posted Nov 02, 2019 - 20:55 GMT
Monitoring
We can see payments successfully confirming now. We're monitoring and trying to get confirmation from Worldpay that things will remain stable. We'll update as we know more.
Posted Nov 02, 2019 - 18:39 GMT
Update
We're talking to Worldpay to try and find out more information on when this will be resolved for you.

Sorry for the disruption to your Saturday.

For now, we'd recommend reserving any tickets so that you can take payment later.

We'll update on here as soon as we have any more info from Worldpay.
Posted Nov 02, 2019 - 18:30 GMT
Identified
If you use Element Payment Services/Vantiv/Worldpay, you might be having trouble processing payments. We’ll keep you updated.
Posted Nov 02, 2019 - 17:57 GMT
This incident affected: Payments Processing (Worldpay (formerly Vantiv)).