Temporary Phone Outage - NY Office
Incident Report for Spektrix
Resolved
Our phones are back online in our NY office, and we are now available for support inquiries as usual. Thank you for your patience as we resolved this issue.
Posted Aug 09, 2018 - 15:08 BST
Investigating
We are currently experiencing a temporary phone outage at our NY office. Our ability to receive incoming support phone calls is limited at this time, so please reach out to us by email at support@spektrix.com with any requests and we will get back to you as quickly as possible. We are working to resolve this outage and will continue to provide updates on our phone status.
Posted Aug 08, 2018 - 20:40 BST
This incident affected: Support Services (Phone Service - North America).