Reports of System Slowness
Incident Report for Spektrix
Resolved
We have had no more reports of slowness and our own monitoring has indicated all issues with clicks redirecting/refreshing are no longer happening.

If you have had delays with print at home emails or auto-tags you should hopefully start to see those come in throughout the afternoon as that backlog clears.

If you do notice any other issues with slowness or any other unusual behaviour please don't hesitate to get in touch with us at Support (support@spektrix.com, 020 7183 3586).
Posted Oct 25, 2019 - 15:03 BST
Update
We are still monitoring the system but we are currently happy with the speed of clicks, and we aren't seeing any issues with clicks redirecting.
There may be some slowness with delivering print at home emails and autotags applying that we will continue to monitor throughout the day.
We will update here again shortly.
Posted Oct 25, 2019 - 14:14 BST
Monitoring
We have implemented a fix that looks to have resolved an issue with clicks re-directing and we are seeing speeds improve as well. We are continuing to monitor this to make sure any slowness, or other issues, don't re-occur. We will provide more updates here shortly.
Posted Oct 25, 2019 - 13:58 BST
Investigating
We are receiving reports of slowness across the system. We are currently investigating the causes of this and are working hard to fix this. We will update shortly with more news when we have it.
Posted Oct 25, 2019 - 13:40 BST
This incident affected: Spektrix System (Spektrix System - UK/IE).