Dotmailer login unavailable
Incident Report for Spektrix
Resolved
Dotmailer have fixed the issue and you can now log in to their site.

It looks like you will be asked to verify your login via email on first attempt. Please make sure you click on the link on the same browser you normally use to access it so your login is verified for future.

If you have any issues please contact Spektrix Support and we'll be able to liaise with Dotmailer if needed.
Posted Jan 16, 2019 - 10:44 GMT
Identified
We have discovered this morning that all logins to Dotmailer (now known as Dot Digital) return an error page.
We are in touch with Dotmailer Support who will provide us with updates that we will pass on as soon as we have them.

Until then, if you don't already have Dotmailer open it looks like it will be inaccessible for a short while whilst they investigate.
Posted Jan 16, 2019 - 09:42 GMT
This incident affected: dotdigital.